<!DOCTYPE html>
<!--[if lt IE 7 ]><html class="ie ie6" lang="en"> <![endif]-->
<!--[if IE 7 ]><html class="ie ie7" lang="en"> <![endif]-->
<!--[if IE 8 ]><html class="ie ie8" lang="en"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html lang="en"> <!--<![endif]-->
<head>

<meta charset="utf-8">
<title>Visualizing periodicity with animations | FlowingData</title>
<meta name="description" content="FlowingData">
<meta name="author" content="Nathan Yau">
<meta name="generator" content="WordPress 5.4.2" /> 
<link rel="stylesheet" type="text/css" href="//cloud.typography.com/7626174/696048/css/fonts.css" />
<link href='https://fonts.googleapis.com/css?family=Inconsolata' rel='stylesheet' type='text/css'>
<link rel="stylesheet" href="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="//flowingdata.com/feed" />
<link rel="pingback" href="https://flowingdata.com/xmlrpc.php" />

<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">

<link rel="stylesheet" href="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/stylesheets/skeleton-3.css">
<link rel="stylesheet" href="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/stylesheets/layout.css">
<!--[if lt IE 9]>
		<script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->

<link rel="shortcut icon" href="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/images/favicon.ico">
<link rel="apple-touch-icon" href="images/apple-touch-icon.png">
<link rel="apple-touch-icon" sizes="72x72" href="images/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="114x114" href="images/apple-touch-icon-114x114.png">
<link rel='dns-prefetch' href='//s.w.org' />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/flowingdata.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css' href='https://flowingdata.com/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://flowingdata.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='bbp-default-css' href='https://flowingdata.com/wp-content/plugins/bbpress/templates/default/css/bbpress.min.css?ver=2.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='hm_bbpui-css' href='https://flowingdata.com/wp-content/plugins/image-upload-for-bbpress/css/bbp-image-upload.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://flowingdata.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.7.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://flowingdata.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://flowingdata.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://flowingdata.com/wp-content/plugins/image-upload-for-bbpress/js/bbp-image-upload.js?ver=5.4.2'></script>
<link rel='https://api.w.org/' href='https://flowingdata.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://flowingdata.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://flowingdata.com/wp-includes/wlwmanifest.xml" />
<link rel='prev' title='Maybe They&#8217;re Just Not Good at Charts Yet (The Process 099)' href='https://flowingdata.com/2020/07/23/process-099-not-good/' />
<meta name="generator" content="WordPress 5.4.2" />
<link rel="canonical" href="https://flowingdata.com/2020/07/23/visualizing-periodicity-with-animations/" />
<link rel='shortlink' href='https://flowingdata.com/?p=61186' />
<link rel="alternate" type="application/json+oembed" href="https://flowingdata.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflowingdata.com%2F2020%2F07%2F23%2Fvisualizing-periodicity-with-animations%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://flowingdata.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflowingdata.com%2F2020%2F07%2F23%2Fvisualizing-periodicity-with-animations%2F&#038;format=xml" />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon-256x256.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon-256x256.png" />
<meta name="msapplication-TileImage" content="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon.png" />
</head>
<body data-rsssl=1>
<div id="main-wrapper">
<a name="top"></a>
<div id="header-wrapper">
<div id="header" class="container">
<div id="logo" class="four columns">
<a href="https://flowingdata.com/">
<img src="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/images/logo-v2d.png" />
</a>
</div>
<div id="nav" class="eight columns">
<ul>
<li><a href="https://flowingdata.com/about/">About</a></li>

<li><a href="//flowingdata.com/category/projects/">
Projects</a>
</li>
<li><a href="//flowingdata.com/category/tutorials/">
Tutorials</a>
</li>
<li class="hide-on-small"><a href="https://flowingdata.com/courses/">Courses</a></li>

<li class="social hide-on-small">
<a href="https://flowingdata.com/newsletter/"><img src="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/images/email-icon100.png" /></a>
<a href="https://twitter.com/flowingdata" target="_blank"><img src="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/images/twitter-logo100.png" /></a>
<a href="https://flowingdata.com/feed" target="_blank"><img src="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/images/rss-icon100.png" /></a>
</li>
</ul>
</div>
<div id="login" class="four columns">
<ul>
<li><a href="https://flowingdata.com/membership/" class="highlight">Become a Member</a></li>
<li>&nbsp;|&nbsp;</li>
<li><a href="https://flowingdata.com/wp-login.php">Log in</a></li>
</ul>
</div>
</div>
</div>
<div id="content-wrapper" class="container">
<div id="single-post" class="archive-post eleven columns">
<div class="nine columns offset-by-two alpha">
<h1>
Visualizing periodicity with animations </h1>
</div>
<div class="clr"></div>
<div class="byinfo two columns alpha">
July 23, 2020
<div style="margin-top:1.5rem">
<h3 class="toplevel">Topic</h3>
<strong><a href="https://flowingdata.com/category/design/" rel="category tag">Design</a></strong> &nbsp;/&nbsp; <a href="https://flowingdata.com/tag/animation/" rel="tag">animation</a>, <a href="https://flowingdata.com/tag/d3js/" rel="tag">d3js</a>, <a href="https://flowingdata.com/tag/periodicity/" rel="tag">periodicity</a>, <a href="https://flowingdata.com/tag/pierre-ripoll/" rel="tag">Pierre Ripoll</a> </div>
</div>
<div class="nine columns omega">

<div class="archive-featured-image">
<img width="750" height="378" src="https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-750x378.png" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-750x378.png 750w, https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-1090x550.png 1090w, https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-210x106.png 210w, https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-768x388.png 768w, https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-1536x775.png 1536w, https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity.png 1934w" sizes="(max-width: 750px) 100vw, 750px" data-attachment-id="61187" data-permalink="https://flowingdata.com/2020/07/23/visualizing-periodicity-with-animations/visualizing-periodicity/" data-orig-file="https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity.png" data-orig-size="1934,976" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Visualizing periodicity" data-image-description="" data-medium-file="https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-750x378.png" data-large-file="https://flowingdata.com/wp-content/uploads/2020/07/Visualizing-periodicity-1090x550.png" /> </div>


<div class="entry">
<p>Pierre Ripoll provides <a href="https://observablehq.com/@pierreleripoll/how-to-visualize-periodic-signals">several ways to visualize periodicity using animation</a>. Moving dots, rotating spheres, concentric circles, oh my. He uses D3.js and it&#8217;s an Observable notebook, so you can see what&#8217;s going on under the hood.</p>
<div class="clr"></div>
 </div>
<div class='yarpp-related'>
<div id="related">
<h3 class="toplevel">Related</h3>
<ul>
<li>
<a href="https://flowingdata.com/2013/01/10/series-of-concentric-circles-emanating-from-glowing-red-dot/" rel="bookmark" title="Series of concentric circles emanating from glowing red dot">
Series of concentric circles emanating from glowing red dot</a>

</li>
<li>
<a href="https://flowingdata.com/2019/07/18/animation-in-visualization-revisited-a-decade-later/" rel="bookmark" title="Animation in visualization, revisited a decade later">
Animation in visualization, revisited a decade later</a>

</li>
<li>
<a href="https://flowingdata.com/2020/03/03/svg-and-css-animations-without-javascript/" rel="bookmark" title="SVG and CSS animations, without JavaScript">
SVG and CSS animations, without JavaScript</a>

</li>
</ul>
<div class="clear-line"></div>
</div>
</div>
</div>
<div class="clr"></div>
<div class="nine columns offset-by-two alpha">
<span id="comments"></span>
</div>
<div class="clr"></div>
</div>
<div id="sidebar" class="five columns">
<div id="membership-sidebar" class="sec centered">
<a href="https://flowingdata.com/membership/">
<p>
<strong>Become a member.</strong>
<br />Support an independent site.
<br />Make great charts.
</p>
<p><small>What you get</small></p>
</a>
</div>
<div id="members-recent" class="sec">
<h3 class="toplevel">Recent Members&#8217; Posts</h3>
<div class="row">
<a href="https://flowingdata.com/2020/07/23/process-099-not-good/">


<h4>Maybe They&#8217;re Just Not Good at Charts Yet (The Process 099)</h4>

</a>
</div>
<div class="row">
<a href="https://flowingdata.com/2020/07/16/process-098-automatic/">


<h4>Automatic Visualization is Still Not Useful (The Process 098)</h4>

</a>
</div>
<div class="row">
<a href="https://flowingdata.com/2020/07/09/process-097-established-charts/">


<h4>Use Established Chart Types, Because They&#8217;re More Straightforward (The Process 097)</h4>

</a>
</div>
<div class="row">
<a href="https://flowingdata.com/2020/07/02/process-096-trynew/">


<h4>Try New Visual Encodings, Because Something Might Work (The Process 096)</h4>

</a>
</div>
<div class="row">
<a href="https://flowingdata.com/2020/06/29/how-to-make-a-spiral-chart-in-r/">


<h4>How to Make a Spiral Chart in R</h4>

</a>
</div>
</div>
</div>
<div class="clr"></div>
<div id="tutorials-list" class="container archive across">
<div class="sixteen columns"><h3 class="toplevel">Projects by Nathan Yau <a href="https://flowingdata.com/category/projects/data-underload/">See All &rarr;</a></h3></div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2019/02/01/how-many-kids-we-have-and-when-we-have-them/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2019/02/more-kids-timelines-feature-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" data-attachment-id="55044" data-permalink="https://flowingdata.com/2019/02/01/how-many-kids-we-have-and-when-we-have-them/more-kids-timelines-feature/" data-orig-file="https://flowingdata.com/wp-content/uploads/2019/02/more-kids-timelines-feature.png" data-orig-size="1440,818" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="more-kids-timelines-feature" data-image-description="" data-medium-file="https://flowingdata.com/wp-content/uploads/2019/02/more-kids-timelines-feature-750x426.png" data-large-file="https://flowingdata.com/wp-content/uploads/2019/02/more-kids-timelines-feature-1090x619.png" /> </div>
<h4>How Many Kids We Have and When We Have Them</h4>
<div class="excerpt"><p>Many parents stop at two kids. Most are done by three. Still, everyone has their own timelines. Here are 1,000 of them.</p>
</div>
</a>
</div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2020/07/02/restaurant-reopenings/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2020/07/restaurants-featured-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" data-attachment-id="60939" data-permalink="https://flowingdata.com/2020/07/02/restaurant-reopenings/restaurants-featured/" data-orig-file="https://flowingdata.com/wp-content/uploads/2020/07/restaurants-featured.png" data-orig-size="2284,1819" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="restaurants-featured" data-image-description="" data-medium-file="https://flowingdata.com/wp-content/uploads/2020/07/restaurants-featured-750x597.png" data-large-file="https://flowingdata.com/wp-content/uploads/2020/07/restaurants-featured-1090x868.png" /> </div>
<h4>Restaurant Reopenings, a Comparison to Last Year</h4>
<div class="excerpt"><p>Restaurants are reopening for dining across the United States. Some states are doing it faster than others.</p>
</div>
</a>
</div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2016/09/21/increased-income-across-all-groups/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2016/09/Change-in-Median-Household-Income-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" data-attachment-id="46370" data-permalink="https://flowingdata.com/2016/09/21/increased-income-across-all-groups/change-in-median-household-income/" data-orig-file="https://flowingdata.com/wp-content/uploads/2016/09/Change-in-Median-Household-Income.png" data-orig-size="843,548" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="change-in-median-household-income" data-image-description="" data-medium-file="https://flowingdata.com/wp-content/uploads/2016/09/Change-in-Median-Household-Income-720x468.png" data-large-file="https://flowingdata.com/wp-content/uploads/2016/09/Change-in-Median-Household-Income.png" /> </div>
<h4>Income Increased</h4>
<div class="excerpt"><p>But not every group&#8217;s median income increased by the same amount.</p>
</div>
</a>
</div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2009/12/21/data-underload-2/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2009/12/underload-21-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" data-attachment-id="29376" data-permalink="https://flowingdata.com/2009/12/21/data-underload-2/underload-2-2/" data-orig-file="https://flowingdata.com/wp-content/uploads/2009/12/underload-21.png" data-orig-size="545,930" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="underload-2" data-image-description="" data-medium-file="https://flowingdata.com/wp-content/uploads/2009/12/underload-21.png" data-large-file="https://flowingdata.com/wp-content/uploads/2009/12/underload-21.png" /> </div>
<h4>Data Underload #2</h4>
<div class="excerpt"><p>Merry Christmas, Bedford Falls! Merry Christmas you old Savings and Loan!</p>
</div>
</a>
</div>
</div>
</div>
<div id="footer-wrapper">
<div id="footer" class="container">
<ul id="final-links">
<li><a href="https://flowingdata.com/about">About</a></li>
<li><a href="https://flowingdata.com/contact">Contact</a></li>
<li><a href="https://twitter.com/flowingdata" target="_blank">Twitter</a></li>
 <li><a href="https://flowingdata.com/newsletter/">Newsletter</a></li>
<li><a href="https://flowingdata.com/feed" target="_blank">RSS</a></li>
</ul>
<div id="bottom">Copyright &copy; 2007-Present FlowingData. All rights reserved.</div>
<div id="bottom-logo"><a href="https://flowingdata.com"><img src="https://flowingdata.com/wp-content/themes/fd-modern-5-8-3/images/logo-lone-v2d.png" /></a></div>
</div>
</div>

<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
var pageTracker = _gat._getTracker("UA-865100-4");
pageTracker._initData();
pageTracker._trackPageview();
</script>
<link rel='stylesheet' id='yarppRelatedCss-css' href='https://flowingdata.com/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='https://flowingdata.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://flowingdata.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202030.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'1938889',post:'61186',tz:'-7',srv:'flowingdata.com'} ]);
	_stq.push([ 'clickTrackerInit', '1938889', '61186' ]);
</script>
</body>
</html>










