<!DOCTYPE html>
<!--[if lt IE 7 ]><html class="ie ie6" lang="en"> <![endif]-->
<!--[if IE 7 ]><html class="ie ie7" lang="en"> <![endif]-->
<!--[if IE 8 ]><html class="ie ie8" lang="en"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html lang="en"> <!--<![endif]-->
<head>

<meta charset="utf-8">
<title>How to make UpSet plots in R, with ggplot2 and ggupset | FlowingData</title>
<meta name="description" content="FlowingData">
<meta name="author" content="Nathan Yau">
<meta name="generator" content="WordPress 5.8.3" /> 
<link rel="stylesheet" type="text/css" href="//cloud.typography.com/7626174/696048/css/fonts.css" />
<link href='https://fonts.googleapis.com/css?family=Inconsolata' rel='stylesheet' type='text/css'>
<link rel="stylesheet" href="https://flowingdata.com/wp-content/themes/fd-modern-5-9/style.css" type="text/css" media="screen" />
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="//flowingdata.com/feed" />
<link rel="pingback" href="https://flowingdata.com/xmlrpc.php" />

<meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes">

<link rel="stylesheet" href="https://flowingdata.com/wp-content/themes/fd-modern-5-9/stylesheets/skeleton-3.css">
<link rel="stylesheet" href="https://flowingdata.com/wp-content/themes/fd-modern-5-9/stylesheets/layout.css">
<!--[if lt IE 9]>
		<script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->

<link rel="shortcut icon" href="https://flowingdata.com/wp-content/themes/fd-modern-5-9/images/favicon.ico">
<link rel="apple-touch-icon" href="images/apple-touch-icon.png">
<link rel="apple-touch-icon" sizes="72x72" href="images/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="114x114" href="images/apple-touch-icon-114x114.png">
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="FlowingData &raquo; How to make UpSet plots in R, with ggplot2 and ggupset Comments Feed" href="https://flowingdata.com/2022/01/25/how-to-make-upset-plots-in-r-with-ggplot2-and-ggupset/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/flowingdata.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://flowingdata.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://flowingdata.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://flowingdata.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='arve-main-css' href='https://flowingdata.com/wp-content/plugins/advanced-responsive-video-embedder/build/main.css?ver=a2e3e8488d9dd3229f145053c8f03dae' type='text/css' media='all' />
<link rel='stylesheet' id='bbp-default-css' href='https://flowingdata.com/wp-content/plugins/bbpress/templates/default/css/bbpress.min.css?ver=2.6.9' type='text/css' media='all' />
<link rel='stylesheet' id='hm_bbpui-css' href='https://flowingdata.com/wp-content/plugins/image-upload-for-bbpress/css/bbp-image-upload.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://flowingdata.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.5.1' type='text/css' media='all' />
<script async="async" type='text/javascript' src='https://flowingdata.com/wp-content/plugins/advanced-responsive-video-embedder/build/main.js?ver=a2e3e8488d9dd3229f145053c8f03dae' id='arve-main-js'></script>
<script type='text/javascript' src='https://flowingdata.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://flowingdata.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://flowingdata.com/wp-content/plugins/image-upload-for-bbpress/js/bbp-image-upload.js?ver=1.1.17' id='hm_bbpui-js'></script>
<link rel="https://api.w.org/" href="https://flowingdata.com/wp-json/" /><link rel="alternate" type="application/json" href="https://flowingdata.com/wp-json/wp/v2/posts/66012" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://flowingdata.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://flowingdata.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.8.3" />
<link rel="canonical" href="https://flowingdata.com/2022/01/25/how-to-make-upset-plots-in-r-with-ggplot2-and-ggupset/" />
<link rel='shortlink' href='https://flowingdata.com/?p=66012' />
<link rel="alternate" type="application/json+oembed" href="https://flowingdata.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflowingdata.com%2F2022%2F01%2F25%2Fhow-to-make-upset-plots-in-r-with-ggplot2-and-ggupset%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://flowingdata.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fflowingdata.com%2F2022%2F01%2F25%2Fhow-to-make-upset-plots-in-r-with-ggplot2-and-ggupset%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="description" content="A more readable alternative to Venn diagrams for when you have more than a few sets." />

<meta property="og:type" content="article" />
<meta property="og:title" content="How to make UpSet plots in R, with ggplot2 and ggupset" />
<meta property="og:url" content="https://flowingdata.com/2022/01/25/how-to-make-upset-plots-in-r-with-ggplot2-and-ggupset/" />
<meta property="og:description" content="A more readable alternative to Venn diagrams for when you have more than a few sets." />
<meta property="article:published_time" content="2022-01-25T19:30:50+00:00" />
<meta property="article:modified_time" content="2022-01-24T16:30:22+00:00" />
<meta property="og:site_name" content="FlowingData" />
<meta property="og:image" content="https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image.png" />
<meta property="og:image:width" content="1652" />
<meta property="og:image:height" content="1120" />
<meta property="og:image:alt" content="" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@flowingdata" />
<meta name="twitter:text:title" content="How to make UpSet plots in R, with ggplot2 and ggupset" />
<meta name="twitter:image" content="https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<link rel="icon" href="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon-256x256.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon-256x256.png" />
<meta name="msapplication-TileImage" content="https://flowingdata.com/wp-content/uploads/2014/10/logo-lone-square-600-5451c585_site_icon.png" />
<style type="text/css" id="wp-custom-css">.postid-65286, .postid-65286 #footer-wrapper {
	background: #58585b;
}
.postid-65286 #header-wrapper {
	border: 1px solid #666;
}
.postid-65286 h1, .postid-65286 h2, .postid-65286 h3, .postid-65286 h4, .postid-65286 p, .postid-65286 #content-wrapper, .postid-65286 .single-feature-post .author {
	color: #f0f0f0;
}
.postid-65286 a.action-button.monthly {
	color: #821122;
}
.postid-65286 a:hover.action-button.monthly {
	color: #fff;
}
.postid-65286 #join-now strong { 	
	color: #fff; 
}

.postid-65286 a, .postid-65286 .meta-bar strong a, .postid-65286  #single-feature-post .author, .postid-65286 #single-feature-post .author a, .postid-65286 #related a, .postid-65286 #header-wrapper a, .postid-65286 #footer-wrapper a {
	color: #fff;
}
.postid-65286 a:hover, .postid-65286 .meta-bar strong a:hover, .postid-65286 #single-feature-post .author a:hover, .postid-65286 #related a:hover h4, .postid-65286 #header-wrapper a:hover {
	color: #fff;
	border-bottom: 1px solid #fff;
}
p.wp-caption-text {
	font-size:.8em;
	line-height:1.2em;
	font-style: italic;
}</style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-66012 single-format-standard post-template post-template-single-long-php">
<div id="main-wrapper">
<a name="top"></a>
<div id="header-wrapper">
<div id="header" class="container">
<div id="logo" class="four columns">
<a href="https://flowingdata.com/">
<img src="https://flowingdata.com/wp-content/themes/fd-modern-5-9/images/logo-v2d.png" />
</a>
</div>
<div id="nav" class="eight columns">
<ul>
<li><a href="https://flowingdata.com/about/">About</a></li>
<li><a href="https://flowingdata.com/membership/">Membership</a></li>

<li><a href="https://flowingdata.com/made-by-flowingdata/">Projects</a></li>
<li><a href="https://flowingdata.com/learning/">Learning</a></li>
<li style="margin-right:0"><a href="https://flowingdata.com/newsletter/">Newsletter</a></li>

</ul>
</div>
<div id="login" class="four columns">
<ul>
<li><a href="https://flowingdata.com/membership/" class="highlight">Become a Member</a></li>
<li>&nbsp;|&nbsp;</li>
<li><a href="https://flowingdata.com/wp-login.php">Log in</a></li>
</ul>
</div>
</div>
</div>
<div id="content-wrapper" class="container">
<div id="single-long-post" class="container archive-post">
<div class="sixteen columns">
<div class="meta-bar">
<strong><a href="https://flowingdata.com/category/tutorials/" rel="category tag">Tutorials</a></strong> &nbsp;/&nbsp; <a href="https://flowingdata.com/tag/ggplot2/" rel="tag">ggplot2</a>, <a href="https://flowingdata.com/tag/r/" rel="tag">R</a> </div>
<div class="clr"></div>
</div>
<div id="top-stuff" class="row">
<div class="six columns">
<h1>How to make UpSet plots in R, with ggplot2 and ggupset</h1>
<div class="author">
By <strong><a href="http://www.maartenlambrechts.com" title="Visit Maarten Lambrechts&#8217;s website" rel="author external">Maarten Lambrechts</a></strong>
</div>
<div id="lead-in-excerpt"><p>A more readable alternative to Venn diagrams for when you have more than a few sets.</p>
</div>
<div id="tut-meta">
<div class="clr"></div>
</div>
</div>
<div class="nine columns offset-by-one">
<img width="750" height="508" src="https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-750x508.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-750x508.png 750w, https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-1090x739.png 1090w, https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-210x142.png 210w, https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-768x521.png 768w, https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-1536x1041.png 1536w, https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image.png 1652w" sizes="(max-width: 750px) 100vw, 750px" data-attachment-id="66298" data-permalink="https://flowingdata.com/2022/01/25/how-to-make-upset-plots-in-r-with-ggplot2-and-ggupset/upset-tutorial-featured-image/" data-orig-file="https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image.png" data-orig-size="1652,1120" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="upset-tutorial-featured-image" data-image-description="" data-image-caption="" data-medium-file="https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-750x508.png" data-large-file="https://flowingdata.com/wp-content/uploads/2021/12/upset-tutorial-featured-image-1090x739.png" /> </div>
<div class="clr"></div>
</div>
<div class="entry ten columns">
<div>
<div class="fadeout">
<p>In addition to a great format for visual jokes, Venn diagrams can clearly show overlap between sets. Sets, as in set theory, can be understood as objects belonging to one or more collections. The classic examples in mathematics are natural numbers, integers, rational and real numbers. But sets are everywhere.</p>
</div>
</div>
<div id="membership-tut-note">
<p>
<strong>To access this full tutorial and download the source code you must be a member.</strong>
(If you are already a member, <a href="https://flowingdata.com/wp-login.php?redirect_to=flowingdata.com%2F2022%2F01%2F25%2Fhow-to-make-upset-plots-in-r-with-ggplot2-and-ggupset%2F">log in here</a>.)
</p>
<p>Get instant access to this tutorial and over a hundred more, plus courses, guides, and additional resources.</p>
<div class="centered" style="margin-bottom:2rem">
<p><a href="https://flowingdata.com/membership/" class="action-button annual">Become a Member</a>
</p>
</div>
<h3>Membership</h3>
<p>You'll get unlimited access to <strong>hundreds of hours</strong> worth of step-by-step visualization courses and tutorials for insight and presentation &mdash; all while supporting an independent site. Source code and data is included so that you can more easily apply what you learn in your own work.</p>
<p><blockquote class="quote smaller" style="margin-top:1.5rem">
The tutorials are very helpful to move from "Oooo, cool!" to how to actually DO the cool.
</blockquote></p>
<p>
Members also recieve a weekly newsletter, The Process. Keep up-to-date on visualization tools, the rules, and the guidelines and how they all work together in practice.
</p>
<p>
See samples of everything you gain access to:
</p>
<ul>
<li><a href="https://flowingdata.com/category/tutorials/">Visualization and Data Tutorials</a></li>
<li><a href="https://flowingdata.com/courses/">Self-Guided Courses</a></li>
<li><a href="https://flowingdata.com/category/the-process/">The Process, a members-only newsletter</a></li>
</ul>
</div>
</div>
<div class="clr"></div>
<div class="author-info sixteen columns" style="border-bottom:none">
<div class="profile-pic two columns alpha"><img alt='' src='https://secure.gravatar.com/avatar/1895114d99a31bac6538964e86121806?s=100&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/1895114d99a31bac6538964e86121806?s=200&#038;d=mm&#038;r=pg 2x' class='avatar avatar-100 photo' height='100' width='100' loading='lazy' /></div>
<div class="bio fourteen columns omega">
<h3>About the Author</h3>
<p>Maarten is a data journalist and data visualization consultant from Belgium. He likes maps, ggplot and a good story.</p>
</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
<div id="tutorials-list" class="container archive across">
<div class="sixteen columns"><h3 class="toplevel">More Tutorials <a href="https://flowingdata.com/category/tutorials/">See All &rarr;</a></h3></div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2018/06/13/how-i-made-that-nationwide-dot-density-map/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2018/05/05native-other-hispanic-asian-black-white-2000x1300-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" loading="lazy" data-attachment-id="51992" data-permalink="https://flowingdata.com/2018/05/16/go-back-where-you-came-from/05native-other-hispanic-asian-black-white-2000x1300/" data-orig-file="https://flowingdata.com/wp-content/uploads/2018/05/05native-other-hispanic-asian-black-white-2000x1300.png" data-orig-size="2000,1300" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="05native-other-hispanic-asian-black-white-2000&#215;1300" data-image-description="" data-image-caption="" data-medium-file="https://flowingdata.com/wp-content/uploads/2018/05/05native-other-hispanic-asian-black-white-2000x1300-720x468.png" data-large-file="https://flowingdata.com/wp-content/uploads/2018/05/05native-other-hispanic-asian-black-white-2000x1300-1090x709.png" /> </div>
<h4>How I Made That: National Dot Density Map</h4>
<div class="excerpt"><p>Mapping one dot per person, it&#8217;s all about putting the pieces together.</p>
</div>
</a>
</div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2015/01/26/choropleth-maps-and-shapefiles-in-r/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2015/01/World-winkel-tripel-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" loading="lazy" data-attachment-id="38713" data-permalink="https://flowingdata.com/2015/01/26/choropleth-maps-and-shapefiles-in-r/world-winkel-tripel-2/" data-orig-file="https://flowingdata.com/wp-content/uploads/2015/01/World-winkel-tripel.png" data-orig-size="620,425" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Choropleth Maps and Shapefiles in R" data-image-description="" data-image-caption="" data-medium-file="https://flowingdata.com/wp-content/uploads/2015/01/World-winkel-tripel.png" data-large-file="https://flowingdata.com/wp-content/uploads/2015/01/World-winkel-tripel.png" /> </div>
<h4>Choropleth Maps and Shapefiles in R</h4>
<div class="excerpt"><p>Fill those empty polygons with color, based on shapefile or external data.</p>
</div>
</a>
</div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2020/08/31/how-to-untangle-a-spaghetti-line-chart-with-r-examples/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2020/08/spaghetti-featured-v2-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" loading="lazy" data-attachment-id="62035" data-permalink="https://flowingdata.com/2020/08/31/how-to-untangle-a-spaghetti-line-chart-with-r-examples/spaghetti-featured-v2/" data-orig-file="https://flowingdata.com/wp-content/uploads/2020/08/spaghetti-featured-v2.png" data-orig-size="1296,882" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="spaghetti-featured-v2" data-image-description="" data-image-caption="" data-medium-file="https://flowingdata.com/wp-content/uploads/2020/08/spaghetti-featured-v2-750x510.png" data-large-file="https://flowingdata.com/wp-content/uploads/2020/08/spaghetti-featured-v2-1090x742.png" /> </div>
<h4>How to Untangle a Spaghetti Line Chart (with R Examples)</h4>
<div class="excerpt"><p>Put multiple time series lines on the same plot, and you quickly end up with a mess. Here are practical ways to clean it up.</p>
</div>
</a>
</div>
<div class="archive-post preview four columns">
<a href="https://flowingdata.com/2014/07/24/how-to-make-an-interactive-treemap/" rel="bookmark">
<div class="archive-featured-image cropped">
<img width="400" height="250" src="https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap-400x250.png" class="attachment-archive-cropped size-archive-cropped wp-post-image" alt="" loading="lazy" srcset="https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap-400x250.png 400w, https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap-210x131.png 210w, https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap-720x451.png 720w, https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap-768x481.png 768w, https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap.png 941w" sizes="(max-width: 400px) 100vw, 400px" data-attachment-id="35843" data-permalink="https://flowingdata.com/2014/07/24/how-to-make-an-interactive-treemap/interactive-treemap/" data-orig-file="https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap.png" data-orig-size="941,589" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Interactive treemap" data-image-description="" data-image-caption="" data-medium-file="https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap-720x451.png" data-large-file="https://flowingdata.com/wp-content/uploads/2014/07/Interactive-treemap.png" /> </div>
<h4>How to Make an Interactive Treemap</h4>
<div class="excerpt"><p>Treemaps are useful to view and explore hierarchical data. Interaction can help you look at the data in greater detail.</p>
</div>
</a>
</div>
</div>
</div>
<div class="clr"></div>
</div>
<div id="footer-wrapper">
<div id="footer" class="container">
<ul id="final-links">
<li><a href="https://flowingdata.com/about">About</a></li>
<li><a href="https://flowingdata.com/contact">Contact</a></li>
<li><a href="https://twitter.com/flowingdata" target="_blank">Twitter</a></li>
<li><a href="https://flowingdata.com/newsletter/">Newsletter</a></li>
<li><a href="https://flowingdata.com/feed" target="_blank">RSS</a></li>
</ul>
<div id="bottom">Copyright &copy; 2007-Present FlowingData. All rights reserved.</div>
<div id="bottom-logo"><a href="https://flowingdata.com"><img src="https://flowingdata.com/wp-content/themes/fd-modern-5-9/images/logo-lone-v2d.png" /></a></div>
</div>
</div>
<script type='text/javascript' src='https://flowingdata.com/wp-includes/js/comment-reply.min.js?ver=5.8.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://flowingdata.com/wp-includes/js/wp-embed.min.js?ver=5.8.3' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202204.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.5.1',blog:'1938889',post:'66012',tz:'-8',srv:'flowingdata.com'} ]);
	_stq.push([ 'clickTrackerInit', '1938889', '66012' ]);
</script>
</body>
</html>










